Sharepoint plugin error message keeps appearing

If you are running legacy versions of Microsoft Office, particularly Office 2007 or Office 2010 pre-SP2, you may experience problems using the Office live editing features in Firefly after update 5.1.9.

Office 2010 SP1 ceased being supported by Microsoft in October 2014 through their mainstream support (http://support.microsoft.com/lifecycle/?p1=13615). Similarly, Office 2007 went out of mainstream support by Microsoft at the end of 2013 (http://support.microsoft.com/lifecycle/?p1=8753).

As a result, you may find you are presented with a Sharepoint plugin error message when trying to live edit an Office document. This new method for opening documents from a browser is the one adopted by Microsoft themselves and can be seen in their online products such as Office 365. If you're using Office 2007 or Office 2010 pre Service Pack 2, we would strongly recommend upgrading so that you can use the live editing feature properly and to avoid the potential security risks that exist with these older versions.